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INSERTING TABLES,  OBJECTS AND 
PRINTING DOCUMENT

7.1 Working With Tables

 A table is a grid with a specified 
number of rows and columns. A well-
designed table can help readers to understand 
better what you are trying to convey. 

7.1.1. Different Techniques To Insert 
Table

There are two methods to create a table :

•  Using table Icon

•  Using Insert Table dialog box

Using Table Icon

 To insert a table quickly from the 
standard tool bar:

1. Place the insertion pointer where you 
want the table to appear.

2. Click the down arrow on the right side 
of the Table icon  on the standard 
toolbar.

3. In the drop down grid, move the 
mouse to select the number of rows 
and columns for the table.

4. The table will appear at the location of 
the insertion pointer.

Using The Insert Table Dialog Box

 To insert a table with more control 
over the settings and properties, use the 
Insert Table dialog box. To open the dialog 
box, click Table → Insert → Table or Ctrl 
+F12.  The Insert table dialog box appears 
as shown in Figure 7.1:

Figure 7.1 Insert Table Dialog Box
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• In the Name text box give a suitable 
name to the table.

• Specify the number of columns and 
rows either using spin arrows or enter 
the value directly.

• Click  the Heading check box to make 
the first row of the table as  heading, 
The Repeat heading check box can 
be enabled to repeat the heading row 
when the table spans more than one 
page.

• Select the Border check box to display 
table with grid.

• Click OK button to create a table.

Entering data into theTable :

 Once the table is created with the 
specified number of rows and columns, 
you are ready to enter data.

 The table is normally created with 
uniform row height and column width 
in the entire area. The insertion pointer 
is placed in the first cell(intersection of 
row and column) and you can start typing 
the text into the cell. You can easily move 
from one cell to the next cell towards 
right by pressing the Tab key and press                  

Shift + Tab to move towards left. Once 
the table is created the Table formatting  
toolbar appears on the formatting toolbar 
as shown in Figure 7. 2. This toolbar can 
also be opened by View → Toolbars → 
Table.

7.1.2 Inserting And Deleting Rows  And 
Columns 

Inserting Rows 

To insert rows in a table there are different 
ways :

1. The easiest way to add a row is to press 
Tab from the last cell.

2. To insert a single row anywhere, place 
the insertion pointer in that particular 
cell and click the Insert row icon  
from the Table Formatting toolbar.

3. To insert  more than one row, click 
Table → Insert → Rows,  the Insert 
Rows dialog box appears as shown in 
Figure 7.3, enter the value using spin 
arrows or type the number directly. 
In the position option, select Before 
or After radio button to specify the 
position of the row. 

4. Click OK button.

Figure 7.2 Table Formatting toolbar
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Figure 7.3 – Insert Rows dialog box

Inserting Columns

 To insert columns there are 
different ways 

1. Place the insertion pointer in the 
particular column and click the Insert 
column icon  to insert a blank 
column right of the insertion point.

2. To insert more than one column, place 
the  insertion point in the particular 
column and click Table → Insert → 
Column, the insert column dialog box 
appears as shown in Figure 7.4, enter 
the value using spin arrows or type the 
number directly. 

3. In the position option, select Before 
or After radio button to specify the 
position of the column. 

4. Click OK button.

Figure 7.4 – Insert Columns dialog box

Deleting Rows And Columns

To delete rows  and columns:

1. To delete a single row, place the insertion 
pointer in the row or to delete more 
than one row, select the rows to be 
deleted and click delete row icon     
from the Table Formatting tool bar 
(or) select Table → Delete → Rows, 
the selected row/ rows will be deleted.

2. To delete a single column, place the 
insertion pointer in the column or to 
delete more than one column, select 
the columns to be deleted and click 
delete column icon  from the Table 
Formatting tool bar (or) select Table 
→ Delete → Columns, the selected  
column/ columns will be deleted.

Deleting Contents of A Table

1. To delete the contents of a table :

• Select the contents of the table to be 
deleted and click Delete key, The 
contents will be deleted, the table will 
remain as it is.

Deleting An Entire Table

1. To delete the entire table :

• Select the entire table by Edit → 
SelectAll or Ctrl + A

• Click Table → Delete → Table

• The entire table is deleted.
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7.1.3 Merging and Splitting Cells

To merge a group of cells:

1. Select the cells to merge.

2. Click Table → Merge Cells or click 
merge cells icon or Right Click → 
Cell → Merge,  

3. The selected cells will be merged into a 
single cell.

To split  a single cell:

1. Place the insertion pointer inside the  
cell.

2. Click Table → Split Cells or click Split 
cells icon  or Right click → Cell → 
Split, the split cells dialog box appears 
as shown in Figure 7.5.

Figure 7.5 Split cells Dialog Box 

3. Select the number of cells to split using 
spin arrows or enter the value directly.

4. Select the direction of the split, 
horizontally (for rows), or vertically 
(for columns).

5. A single cell is split into the desired 
number of rows and columns.

7.1.4 Resize the position of Table

 A newly created table will occupy 
the entire width of the page area by 
default. The table can be resized as per our 
requirement:

• To resize a table quickly, move  the 
mouse  over the table edge until the 
cursor becomes a double headed arrow, 
and drag the border to its new desired 
position.

To resize a row height / column width 
using Mouse :

To resize row height

• Move the insertion pointer over  the 
horizontal border for the row height 
now the insertion point will change 
into double headed arrow , click and 
drag to resize the row height.

To resize column width

• Move the insertion pointer over  the 
vertical border for the column width 
now the insertion pointer will change 
into double headed arrow , click and 
drag to resize the row height.

To resize column width using dialog box

• To give precise measurement for 
column width, Click Table → Table 
Properties, the Table Format dialog 
box as shown in Figure 7.6
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Figure 7.6Table Format Dialog Box

• Click the Columns tab. In the column 
width spin box enter the new column 
width or use spin arrow for the 
columns.

• Click OK button.

• The width of columns are resized as 
per the new values.

7.2 Formatting The Table 

 Formatting a table involves 
formatting of the table layout, formatting 
of the table text, changing borders, 
background and autoformating.

7.2.1Changing Background

 To change the background of a 
table in a document:

 Place the insertion pointer inside 
the table.

1.  Select Table → Table Properties.

2. Select the Background tab inside the 
Table Format dialog box as shown in 
Figure 7.7.

3.  In the For section, choose to apply the 
background to the cell, row or table.

• Cell: To apply background to  a cell or 
a group of selected cells.

• Row: The background will be applied 
to the entire row or group of selected 
rows.

• Table: The background will be applied 
to the entire table.

4. In the As section, choose to apply a 
color or graphic:

• To apply color, select the color from 
the color palette and click OK button.
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Figure 7.7 Table format dialog box - Background

• To apply graphic, select Graphic, click on the browse button to select the required  
image file and click OK button. The image appears in the selected cell as background.

7.2.2 Changing Text Direction In Table

 To change the text direction 

• Select the text to change the direction in the cell.

• Select  Format → Character, the character dialog box appears.

• Click Position tab, in the Rotation / scaling option, 

• Select the required rotation angle(0, 90, 270, Fit to Line) and click OK. 

7.2.3 Changing Table Border

 To change the table border, select Table → Table Properties, the Table Format 
dialog box appears, select Borders Tab , you can set the borders for a table or a group of 
cells.
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Figure 7.8Table format dialog box to apply borders

Properties of Border

• Line arrangement specifies how the borders apply.  Writer provides five arrangements 
as shown in Figure 7.9, you can modify the arrangement by clicking on the line 
arrangement you want to customize.

Figure 7.9 Line Arrangement

• Line option specifies the border style. 

• Color option helps to select the color of border line.

• Spacing to contents option specifies how much space to leave between the border and 
cell contents. 
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7.2.4 Autoformating Table

 The AutoFormat option helps to 
format the table with predefined styles. 
This is a simple and easy way to format 
tables. AutoFormating can be applied by :

• Create a Table with the desired number 
of rows and columns.

• Click Table → AutoFormat

• A set of already designed  styles with 
predefined names are available in the 
Auto Format dialog box as shown in 
Figure 7.10.

• Select the desired style and click OK 
button.

• The selected style is applied into your 
table.

Figure 7.10  Auto format Dialog Box

7.3 Inserting Formulae in Tables

We can use formulae in Writer to perform 
spreadsheet like calculations easily.

To perform calculations on the data in the 
table

• Create a Table with the following data:

Item 
sold Jan Feb Total 

Books 15 70
Pens 30 50
Ruler 25 25
Total 
Goods

Click in the empty cell where you want a 
calculation. 

• Choose Table → Formula or press F2 
and you will get the spreadsheet-like 
toolbar with the formula entry field.

 

Figure 7.11Formula Tool bar

• If  you want to add a range of cells then 
in the current cell type = <B2:B4>and  
press Enter key. The total will appear 
as given in the example below.

This method is applicable only to find 
summation of the selected range. The 
cell address must be in capital letters.

NOTE 

Item 
sold Jan Feb Total 

Books 15 70
Pens 30 50
Ruler 25 25
Total 
Goods

 =<B2:B4>

• The formula Toolbar as shown in 
Figure 7.11 can be used when the user 
wants to perform other arithmetic 
calculations.  



108 109

Item 
sold Jan Feb Total 

Books 15 70 =<B2>+<C2>
Pens 30 50
Ruler 25 25
Total 
Goods

70

• If you want to perform calculations 
using individual cells, individual cell 
reference should be placed within <> .

Note : In the table structure the columns 
are labelled as A, B, C……and the rows 
are numbered as 1,2,3,…… etc. For Ex. 
The first cell is referred as A1, B1 etc.

• In the above example, to find the  sum, 
of the books purchased in January and 
February, the total is calculated using 
the formula =<B2>+<C2>. 

• A subtraction formula for instance is 
given as =<B2>-<C2>.

• If you want something more 
complicated  than   addition, subtraction, 
multiplication, and division, click on 
the formula dropdown list as shown in 
Figure 7.12.

Figure 7. 12 Formula dropdown list

Workshop

7-1 Open a new document.

• Using icon or table menu create 
the given table with 5 rows and 
6 columns with the labels S.No., 
Name, Maths, Phy, Che and Total 

• Calculate the Total of three subject 
using SUM functions.

• After the sixth row add a new row  
and type suitable data for the new 
row.

• Delete the second row using icon 
or command.

• Using icon or command after the 
second  column add  a new column 
and type suitable data for the new 
column.

• Delete any one column using icon 
or command.

• Save and close the document.

7-2 Open the  document created in 
workshop-7.1.

• Do the following options

• Change the border style and 
border line width for one table.

• Change height and width for the 
row and column respectively.

• Save and close the document.
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7.4  Inserting Objects

7.4.1 Inserting And Formatting Pictures

 Open Office Writer has the ability 
to insert and edit images in a simple way. 
The picture gallery of the Writer consists 
of a collection of images from which the 
desired image can be selected and inserted 
into the document. To insert an image 
from a file, the steps are as follows:

• Place the insertion pointer where you 
want the image to appear

• Select Insert → Picture → From file

• The insert picture dialog box appears 
where the picture gallery opens from 
which the desired picture can be 
selected.

• If the picture is not in the gallery, then 
browse the picture from the folder, 
choose the desired picture.

• Click on the Open button.

Figure 7.13 Picture Toolbar

7-3 Create a new document.

• Create a 4 x 4 table using icons in 
toolbar or using commands.

• Split any one row/ column in one 
given table into more than one cell 
using icon or command.

• Merge any two or more row / 
column in the given table using icon 
or command.

7-4 Open the document created in 
workshop-7.1.

• Delete the table content.

• Perform all  table formatting options 
for this table.

• Add two more rows and columns and 
also delete the rows and columns.

• Save and close the document.
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• The selected picture is inserted into 
the document. Figure 7.13 shows the 
Insert Picture dialog box.

Formatting Pictures

 Using Picture toolbar of Writer 
one can modify the format of the inserted 
picture. 

 A click inside the picture displays 
the picture toolbar as shown in Figure 
7.14 which helps to format the picture 
by cropping the picture, adding borders, 
setting the height and width, changing the 
background color and performing various 
other formatting.

Figure 7.14 Picture Toolbar

• To increase and decrease the size of 
the picture, click and drag at the four 
corners.  

• Clicking on Crop tool displays the 
cropping handles, Click and drag a 
handle to crop an image. Click the Crop 
command to deselect the crop tool.

• Clicking on Default drop down arrow  
displays options like Black and white, 
Grey scale or Water mark (background)  
while default option displays the 
picture as original.

• Clicking on Flip horizontally icon  
 flips the picture horizontally.

• Clicking on Flip vertically icon  
flips the picture vertically.

• Clicking on Transparency icon  
helps to adjust the clarity of the picture 
in %.

7.4.2 Inserting Special Character And 
Equations

 Many symbols which are used in 
a mathematical equation like alpha (∞), 
beta (β), pi (π) etc., are not available on the 
standard keyboard. However,representing 
these characters are very much essential 
in mathematical equations. To insert such 
characters, the procedure given below is 
followed: 

Figure7.15 Insert Symbol Dialog box
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• Place the insertion pointer in your 
document where you want the 
character to appear

• Click on the Insert → Special Character

• The Special Character dialog box 
appears as shown in Figure 7.15 from 
which the desired symbol can be 
selected by clicking  on the character.

• Click the OK button to insert the 
special character.

Open Office Writer helps to insert 
mathematical equations using the various 
symbols. These equations can be inserted  
by following the steps below:

• Click on the Insert → Object → 
Formula

• The equation editor opens at the 
bottom of the screen.

• Click in the equation editor  and type 
the equation.

• To include symbols in the equation 
Right-click in the equation editor and 
select the symbol from the pop-up  
menu.

• Click inside the document to include 
the equation in the document and this 

will automatically exit  the control 
from equation editor. 

• Double-click on a formula to edit the 
equation.

7.4.3 Inserting And Editing Shapes 

OpenOffice Writer uses the drawing tools, 
to create various shapes by using the 
Drawing toolbar. Select View → Toolbars 
→ Drawing to display Drawing toolbar 
as on Figure 7.16 which contains various 
drawing tools.

To use a drawing tool:

• Click in the document where you want 
the drawing. 

• Select the tool from the Drawing 
toolbar. The mouse pointer changes to 
a cross-hair pointer. 

• Move the cross-hair pointer to the 
place in the document where you want 
the drawing to appear and then click-
and-drag to create the drawing object. 
Release the mouse button. The selected 
drawing function remains active, so 
you can draw another object of the 
same type. 

• To cancel the selected drawing function, 
press the Esc key or click on the Select 
icon on the Drawing toolbar. 

Figure7.16 Drawing toolbar
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• You can now change the properties 
(fill color, line type, width, etc.) of the 
drawing object using the Drawing 
Object Properties toolbar.

• Click on T Icon to create a text box and 
type any amount of text which can be 
moved anywhere into the document.

7.4.4  Inserting Page Break

 OpenOffice Writer inserts a page 
break automatically when the content 
exceeds a page, this is known as soft page 
break. Sometimes the user need to insert 
a page break manually, it is called as hard 
page break.

1. Place the insertion pointer in the 
document where the page break is to 
be inserted.

2. Select Insert → Manual Break, the 
Insert break dialog box appears as 
shown below in Figure 7.17.

Figure  7.17 Insert Break dialog box

3. Under the type option choose Page 
break and click OK button .

4. A page break is inserted at the current 
location.

7.4.5 Inserting  Word Art

 WordArt is a feature in OpenOffice 
Writer which  includes effects such as 
shadows, outlines, colors, gradients, and 
3D effects that can be added to a word or 
phrase to make it more presentable and 
attractive. 

To insert WordArt , the steps to be 
followed are :

• Click the Fontwork icon  on the 
Drawing toolbar.

• Fontwork gallery window with various 
font work is displayed as in Figure 7.18.

• Double-click on the required Font 
work style, and type the required word 
or phrase and click OK button.

 
Figure 7.18WordArt Dialog Box

7.4.6 Inserting Auto Text

 AutoText allows the user to assign 
text, tables, graphics and other items to 
a key or key combination. For example, 
rather than typing "TamilNadu" every 
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time you use that phrase, you might just 
type "tn" and press F3.You can also save a 
formatted Tip as AutoText and then insert 
a copy by typing "tip" and pressing F3.

To assign AutoText shortcut to some 
text, the steps are as follows:

1. Select the text for which shortcut is to 
be created. So that it is highlighted.

2. Select Edit → AutoText (or press 
Ctrl+F3).

3. In the Name textbox, type the shortcut. 
Writer will automatically show one 
letter shortcut in the Shortcut textbox.

4. Click the  of the AutoText button 
on the right and select New (text only) 
from the menu.

5. Click Close to return to your document.

6. Once the entry is created, to insert the 
auto text into the document, place the 
insertion point  where the text is to be 
inserted and click Ctrl+F3.

7. Select the name from the list of entries 
and  click Insert button or type the 
shortcut and press F3.

8. The auto text is inserted into your text.

Figure 7.19 Auto text Dialog Box

Note
If the only option under the AutoText button is Import, either you have not 
entered a name for your AutoText or there is no text selected in the document.

7.5 Page Preview, Setting the printer and Printing a Document

7.5.1 Preview the document to be printed

 It is a good practice to preview the document before taking the print out. The steps 
to  be followed to preview the document :
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1. Click File → Page Preview, or click the Page Preview button . The Writer displays 
the Page Preview toolbar displayed on Figure 7.20.

Figure 7.20 Page Preview Toolbar

2. In the page preview toolbar click Multiple pages icon to display multiple pages.

3. To close the preview click on Close Preview button.

7.5.2 Setting the Printer and Printing

The following are some steps to change the printer setting :

1. Click File → Print or Ctrl+P  or Print File icon which opens the Print dialog box that 
appears as shown in Figure 7.21.

Figure 7.21 Print Dialog box

2.  Click  General tab.

3.  Select the required printer from the list of printers 

2. Under Range and copies section : select All pages option to print  all pages, select 
Pages option to specify the particular page or page range.

3. Specify Number of copies using spin arrows.

4. Click Print button.
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Impress

Calc

Writer
Database

Workshop

7-5 Open the  document created in 
Part-1 workshop-1.

• Download images related to Dr. 
A.P.J ABDUL KALAM from 
internet and insert the images in 
the document at required place 
using command or icon.

• Open the document in Part-III – 
workshop-1 , download images  
related to the content  from 
internet and insert the images at 
required place.

• Save the document and close.

7-6 Open a new  document.

• Using the commands to insert 
special characters, special symbols

• Type the following equations (i) 
Aα+Br+cβ  (ii) πr2h.

•  Using drawing toolbar insert 
various drawings/ shapes in your 
document 

• Save and close the document.

7-7 Open the  document created in 
workshop-2

• Using Autotext command or 
keyboard shortcut create shortcut 
for  “Vital Information Under 
Seize” as “VIRUS” and make it 
appear in one document.

• Using Print icon change printing 
attributes, preview and print the 
document.

7-8 Open the  document created in 
workshop-4 of part I of ch-6

• Insert suitable picture of a circle.

• Type the formula for the 
circumference of a circle using 
insert special character option.

• Using drawing tools draw the 
following in the document.

• Print the document using print 
command.
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Activity

Student Activity 

1.  Based on the concept of calculation using formulae, make the students type the  Mark 
sheet in a table and calculate their total and average in writer.

2.  Make the students prepare a invitation for school annual day with school name as 
Watermark.

3.  Let the students prepare their class timetable in table format and format it in an 
attractive manner.

Teacher Activity

1.  To show a demo to the students how to type a question paper by using formulas and 
special characters, changing the margins and printing in the practical session.

2.  To show the students a demo of inserting a picture and applying crop , color changes, 
background and others features to modify it and make more attractive.

Evaluation

Part I Choose the Best Answer

1. To give precise measurement for column width, which command gets the  Table 
Format dialog box?

  a. File→Table properties b.Format→Table properties

       c. Table→Table properties d. Table →Table format.

2.   Which option helps to assign text, tables, graphics and other items to a key or key 
combination?

  a. Autoformat b. Automatic

  c. Auto text d. Autographics

3.   Which command on the insert menu is used to insert a page break in the document?

  a.ManualBreak b. Hard page break

  c. Section break d. Page Break
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4.   What is the short cut key to open the insert table dialog box?

  a. Ctrl + F5 b. Ctrl + F8

  c. Ctrl + F10 d. Ctrl + F12

5.   Which icon on the drawing toolbar gets you a text box?

  a. Text icon b Text box icon

  c. Draw icon d. Draw box icon

Part II  Very Short Answers

1.   How do you insert pictures in to your document?

2.  Write the steps to insert special characters in a document?

3.  How do you  split and merge cells in a table?

4.  What is the use of WordArt in writer?

Part III Short Answers

1.  Write about the drawing toolbar

2.  How  do you insert rows and columns?

3.  How do you change the clarity of the picture in background?

Part IV  Explain

1. Write the steps to create autotext for a word.

2.  How do you resize the position of a table?

3.  How do you format pictures?

4.  Write the steps to preview before printing and steps in printing a document.

5.  Write the steps to compute the sum for a set of data in a table by using formulae.


	Index
	Chapter 1
	Chapter 2
	Chapter 3
	Chapter 4
	Chapter 5
	Chapter 6
	Chapter 7

