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Introduction

Digital content can be in any form. We have different types of files, such as  

images, videos, audio, text files, software program files which can be compiled and 

made executable. Following is the list of contents along with its example

 1.  Images files

 2.  Blogs – HTML files with Images and Videos in it.

 3.  Audio Files – Mp3 and various other format files etc.

 4.  Videos files –  

In this SOP we are going to learn GIMP, Inkscape

GIMP

GIMP (GNU Image Manipulation Program) was created in 1995 as a computer sci-
ence project by students, Spencer Kimball and Peter Mattis. Today GIMP has become 
a very sophisticated software with plenty of documentation and support. GIMP is a 
Free and Open Source Software. You can freely distribute the program as well as its 
source code to any number of users. You can even study the source code and enhance 
it. GIMP runs on Linux and most of the other desktop Operating Systems.

Fig 1 : GIMP Opening Screen
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Gimp Opening Screen  (The appearance may vary depending upon your version)

GNU/Linux distribution already comes with a GIMP package. Installing through 
package manager is a preferred method of installing GIMP, as the distribution main-
tainers take care of all the dependencies and bug fix updates. 

GIMP is very easy to learn. The opening screen of 
GIMP is shown above. Please ensure that you use 
the 'Single Window Mode' which is suitable for 
beginners. To do this,  tick  Windows -> Single-
Window Mode if it is not ticked already.

GIMP toolbox contains set of tools. These tools can be used 
to do various operations on images. Tool icons visually describe 
the corresponding operations. We will cover a few of them.

Students are required to explore the other tools by using 
them and referring to the GIMP documentation, manual and 
web tutorials which are freely available.

The most frequently used  tool is Foreground 
and Background colour tool. The upper rectangle 
represents foreground colour while the lower 
represents background. 

Clicking on each of the rectangles gives a colour selection dialog from which users 
can choose required forground or background color. Note that each colour selection is 
represented by set of numbers. You can note down these numbers and reproduce the 
colour at any time. 

Let us do a small activity. We will create a colourful baloon with some text on it. 

Step 1 : Create a blank image, also called as ‘Canvas’. File->New (or Ctrl+N).

Fig 2 : Single Window Mode Option

Fig 3 : GIMP Toolbox

Fig 4 : Canvas Creation
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We start with a new blank  image of size 640 x 400 pixels. The new image will 
have white background and black foreground.

This 640 x 400 image will be the surface of our baloon.

We want our baloon to have very attractive colours. So let us fill the whole image 
area with some bright colour. We can use single flat colour or even mixture of few col-
ours. Here we will use gradient colour. Gradient colour is a gradually fading mixture 
of two colours

Step 2 : Change Foreground and Background colour with colours of your 
choice. The tool will show you the colours you have chosen in the form of 
small icon.

Fig 5 : Colour Toolbox

Step 3 : Now select the Blend Tool ( short cut L )  from the tool box and drag the 
mouse from left to right on your canvas. After you release the mouse, the canvas will 
be filled by the gradient of foreground and background colour. The baloon made up 
of this canvas will look nice. But we will decorate the canvas further by putting some 
text and coloured ovals on it.

Fig 6 : Gradient Color
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Step 4 : Next click on Text tool ( short cut  T ) The resulting dialog will give you 
various options to change font, font size, colour of the font etc. You can type text in the 
language of your choice provided that additional languages are added in Region and 
Language Settings of your Linux Distribution. You can refer QR Code to install 
Marathi Font.

Step 5 :  After you are satisfied with the font, size and other attribute, press escape. 
Note that a new layer is created with the text you entered. As you add various objects 
like text,graphics,drawings etc to your image, new layers are created. This enables 
you to selectively move the objects and change their colour, size etc. Later you can 
merge down these layers into your main image.

Step 6 : Using move tool, we can move the text roughly to the centre of the image but 
instead we prefer to put it precisely in the centre, using the Align Tool. Click on Align 
Tool ( short cut Q )  and then select the Text layer and text. In the Align dialog, Select 
relative to image and click on Vertical Centre and then Horizontal Centre buttons. The 
text layer should now occupy the exact centre of the image.

Step 7 : Drawing coloured oval (Ellipse) : Change the background and foreground 
colours again with two different colours. We have chosen Red and Yellow respectively.

Create a new layer in your image. Now click on the Ellipse select tool (short cut E) 
and select the oval shaped area on the image. It will not have any colour.  Use the 
menu Edit->'Fill with FG colour' to give Red colour to your oval. Similarly draw 
another one and fill with BG color. 

Step 8 : Using move tool place these ovals near the Text. Do not move them too far 
from the center or they will go to the rear side of the baloon. Select the layers one by 
one and merge them using the command Layer->Merge Down. We now have a colourful 
single layer. Let us create a baloon from this canvas.

Fig 7 : Text Tool

BalBharatiDev01 
font can be 
downloaded from 
ebalbharati site 
(if required)
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Step 9 : Do Filters->Map->Map Object. Select Map to Sphere, Check 'Update preview 
live' and Uncheck the 'Transparent Background'. This will give you a dialog showing 
the preview of the resulting balloon (sphere)

Press Ok and the image will now turn into nice 
balloon with 3D effect. 

The balloon is little elongated since our canvas 
was rectangular. 

Fig 8 : Output till step 8

                                                                                     Fig 9 : Map to Object Tool

Fig 10 : Output for Step 9
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Step 10 : We will tweak the balloon further and give it more realistic shape. Apply the 
Distort Filter with Curve Bend option. That is Filter->Distort-> Curve Bend. In the 
resulting dialog choose Automatic preview and Lower curve border. Then drag the 
Mid point of the Curve Indicator line using the mouse :

Press Ok and you will get a nice colourful balloon with 3D effect.

Step 11 : Let us remove the unwanted portion around the balloon. To do this simply 
do Image-> Crop to content.

Fig 11 : Curve Bend filter Option

Fig 12 : Output for Step 10
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Step 12 : Finally export the image to PNG (jpg format does not support transparency) 
You can use this balloon as the object to other images. Open an image where you want 
to insert the balloon.

Fig 13 : Output after cropping

Fig 14 : Image for Step 12
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File -> Open -> Image ->As Layer. Then move the balloon layer to the desired location 
and merge the balloon layer to the original image. Note that the transparent part is not 
visible. All images are rectangular in shape. Due to transparency our image appears to 
have balloon like shape.

Fig 15 : Output for Step 12
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Inkscape 

Inkscape is a free and open source software for creating vector images. 
Vector Images are stored as drawing rules and not as a set of pixels.  
Whenever we resize a vector  image, the image is redrawn using the rules.  
Hence the resized images have the same quality as that of original images.

The image rules or descriptions are stored in xml format with the  
extension SVG (Scalable Vector Graphics). Inkscape is primarily used for diagrams, 
charts, graphs, illustrations, logos, icons, line arts, user interfaces of softwares etc.

Inkscape is availble on all major desktop operating systems. It is included in official 
repositories of all major Linux distributions. One can easily install it from package 
manager like Synaptic.

Fig 16 : Inkscape Opening Screen
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The opening screen gives you a toolbar on the left. On the top you have a tool 
control bar. When a tool is selected, this bar shows various settings for the currently 
selected tool. The right side is reserved for additional dialogs such as fill and stroke 
align and distribute etc.

We will draw simple objects in order to learn basic skills using the given tools. 
We use only geometric shapes such as line, circle, ellipse, rectangle and square for  
these drawings. You might already have used similar tools in many other drawing and 
painting softwares. But Inkscape gives you far better control than most of the other 
softwares.

Circle/Ellipse Tool :

Let us start with Circle or Ellipse tool. 

1)  Select the tool button from left tool bar showing circle icon. 

2)  Drag it with the mouse to any place in the client area. You will 
get a circle or an ellipse from starting point to the end point where 
you release the mouse button. To get the exact circle, press the Ctrl 
key while dragging. This will guide you by snapping to the exact 
square.  

3)  After the ellipse is complete choose the selection tool (topmost from the left tool 
bar). Then click on the ellipse. The ellipse will then show 8 size handles. You can 
resize the ellipse by dragging these handles. Also clicking once again on it will turn 
the sizing handles to rotation handles. You can toggle between Size and Rotation 
handles.

Fill Colour in the object :

To fill the ellipse with colour, just click on any desired colour given in the bottom  
colour palette. 

To choose  more precise and accurate colours, use the menu Object - Fill and 
Stroke. This will give a dialog with a few tabs and also Red, Green and Blue (RGB) 
colour options. You can choose any combination of Red, Green and Blue to obtain very  
precise colour from it. Note that you have 0 to 255 that is total 256 choices for each 
of Red, Green and Blue so total 256 x 256 x 256 = 16777216  colours can be chosen.
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Duplicate the object :

Using duplicate, you will get an exact copy of the object. Using Edit-Duplicate 
(Shortcut Ctrl-d) you get exact copy of the same object. The duplicate will be at the 
same place so you need to move it in order to make the duplicate object visible.  

Activity :

Draw different sized ellipses, fill them with colour, rotate and then 
move and position them in order to draw a simple object as shown 
below . Our example object is an animal made up of ellipses.  A 
squirrel is shown using only ellipse. We have applied duplication 
of objects, colouring, rotation and order of objects at appropriate 

places. You can draw any other animal using simple objects.

Objects may overlap each other. This order of Objects can be changed by using menu 
Object -> Raise to Top, Lower to Bottom.

To draw line segments, use Bezier tool. After selecting the tool, click at starting 
point and drag with mouse to draw line , double click to finish the segment at desired 
point. Now to increase the line width, click on menu Object -> ‘Fill and Stroke’,   while 
the line segment is selected. In the ‘Stroke Style’ tab, adjust the width.

To change the stroke paint, go to stroke paint tab in the same dialog and choose 
the desired colour. You may have to press shift at the time you click on colour in  
order to apply it. To draw a vertical or horizontal segment with precision, keep Ctrl key 
pressed during the drawing. This will correct the angle in steps of 15 deg as you move 
closer to the angle.

Using the node tool, transform the drawn segment into a 
curve. Select the tool and stretch (drag) the  middle part 
of the segment. It will turn into  a curve

Let us fill this curve with a colour. It is very simple. Just select the 
object (curve in our case). Ensure that 8 sizing handles are surrounded 
by the object. Then click on the required colour. We have chosen 
Green colour. This will fill the region under the curve.

Now we draw a circle or ellipse. You are already familiar with this. Pick this 
tool from the left tool box and drag it on the canvas with left mouse button. 
Rlease the mouse button after you get the desired size of the ellipse. To  
produce exact circle, keep the ctrl button pressed. In the same way, 
rectangles or squares are drawn. We also draw two small ovals and fill 
them with a suitable colour.
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We will draw another curve by stretching the line segment 
downwards.  Fill it with some colour and join these two curves. 

Bring together these shapes to form a simple basic human figure. 
You need to select and move them in order to put them at proper 
places. You can use Edit->Duplicate (Shortcut Ctrl+d)  for pair of 
feet.. Also use rotate handles to rotate the object. Sizing handles are 
converted to rotate handles on click and vice versa. 

Here is another example. A small bird with colourful wings, 
tail, beak and legs. All the components are geometric shapes 
that are joined together. Legs and Wings can be drawn and 
duplicated.

The adjacent diagram shows the drawing components 
used to make bird.

Gradient in Inkscape :

Let us now learn another concept in colouring, the Gradient. Gradient is a gradual 
mixture of colours. Gradients are used to give special effects to paintings. Gradients 
look attractive. They often give a kind of depth to the shapes. 

Activity to draw a staircase :

1)  Draw a parallelogram using beziar tool. Ensure that the last node will coincide 
with the first. This will make the region closed.

2)  Now choose a plane colour to fill this region. We have chosen red. Go to menu 
Object->Fill and Stroke. Ensure that the region is filled with proper colour and the 
Fill tab is selected.

3)  Finally click on Gradient tab. The region is now filled with red gradient slowly 
fading towards the other end with white colour. This is the upper surface of a 
staircase step. 

4)  Duplicate this object and move a little down words to get the bottom surface.
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5)  Next draw another paralelogram of appropriate size for the front surface. Fill this 
surface with Green Gradient.

6)  We do not require the rear surface. A small edge may be drawn instead to indicate 
the rear surface of the step block.

7)  Join all components. Completed single staircase block is shown in the adjacent 
figure. 

8)  Finally take multiple copies of this block and make a staircase object.

Always ensure that the desired color is filled in the region of the 
object before selecting gradient tab.

When duplicate is created it will be placed just above the original 
object. Select and move it immediately from its place to avoid 
multiple copies one below the other. This will unnecessarily 
increase the size of the image.

Palette gives only the standard set of colours. You can use Fill and Stroke dialog 
and RGB model tab to adjust the colour with more accuracy. There are CMYK and 
other models to select the colour. Study of colour models is beyond the scope of this 
text book. Students are encouraged to study this advance topic.

Activity to draw a simple flower :

1) Draw one elongated ellipse. This is a petal of our flower.

2)  Fill with pink colour.

3)  Click on it to get sizing handles. Again click it to get rotation handles. Look 
carefully at the center of the ellipse. There you will find the center of rotation. If 
you try to rotate this petal using the handle, it will rotate around this center. We will 
move this center to left corner. To do this just drag it with mouse.

4)  Now duplicate the petal (Ctrl+D). This operation will also copy the new location 
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of the center. Now if you rotate the petal. It will move along its corner like needles 
of the clock.

5) Duplicate and move these petals successively to get complete
round of petals resulting into a flower.

6) We can decorate the flower further by adding colourful center.
Draw a circle. Fill it with a bright colour, say red. In the fill
and stroke dialog, increase the stroke width in stroke style tab.
Choose a different stroke paint, we have chosen yellow. Now
move this circle to the center of the flower.

7) Finally, we attach a stem to our flower. There is a calligraphy
tool. This tool a used to write stylish text. This is a kind of
angled pen. As you change the direction of the stroke, the
width of the stroke changes. Draw a smooth curved stroke as
shown. Also draw two ellipses for leafs. Give green colour to
these objects. Use duplicate the leaf and use flap command to
avoid repetitive work.

8) The completed flower is shown in the adjacent picture.
Gradients can also be used to colour the petals. You can see
in another example, the petals are coloured with yellow and
orange color gradients. Try to draw different  flowers and find
out more tools that can be used for creating flowers.

Activity to draw Star and Polygon :

The next tool that we are going to try is Star and Polygon tool. 

1) Open this tool. You can switch between star and polygon by the buttons given in
this tool’s settings.

2) Drag Stars or Polygons of various sizes. One fascinating thing about star tool is
that the underlined algorithm can produce different design patterns as you change
basic parameters which create the star. Try experimenting on number of corners,
spoke ratio and rounded setting.
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Corners : 9 Corners : 16 Corners : 24 Corners : 24
Spoke Ratio : 0.608 Rounded : 0.050 Randomized : 0.128 Spoke Ratio : 0.560
Rounded : 5.010 Rounded : 4.600 Rounded : 5.010 Rounded : 6.990

Activity to draw a Snail :

Just below the star tool, there is spiral tool which can be used to 
draw the spirals of all sizes and styles. You can set number of turns 
and also the other parameters. Let us use spiral object to draw an 
interesting object, a snail. The shell of a snail has spiral pattern. 

1) Draw a spiral and increase the stroke width.

2) Draw ellipse for body of the snail and use appropriate tools for other parts.

3) Draw traingle as a tail, small circles as eyes, rectangle & filled circel as antenna
of the snail.

Activity to draw a Car :  

We will now take a look at the Simplify path command. This command gives 
smootness to the curve. The edges or corners are removed and replaced by smooth 
curve. It is a recurring process, that is you can give the command Path -> Simplify  
(Shortcut Ctrl + L)  repeatedly till you get the desired result. 

As an activity, let us draw a simple car object using bezier 
segments.  
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 1)  Using Bezier tool, draw an outline of a car by 
using a series of segments. Close the outline by 
choosing the first node as last node. 

 2)  Now select the car outline and press Ctl+L 
(Shortcut for Path -> Simplify. Corner nodes 
will slowly turn into curves. You can stop when 
desired seamless shape is obtained. In case you 
go ahead and smooth it more than required, you 
can always press Ctrl+Z (undo) 

3)  After you get the outline in good proportion,colour the car.

4)  Create two wheels (circles) with thick stroke.

5)  Give appropriate fill and stroke colour.

6)  You may draw some strips to represent street.  You may need to order the object 
using Object -> Raise to Top, Lower to Bottom.

Activity : Move the mouse pointer on the toolbar and identify the tools. Make a list.
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SOP 1 :  Use of Toolbox and editing an image using GIMP.

  Create an image by using Toolbox  controls from GIMP.

 	Insert the image in an already created image. 

SOP 2 : Use GIMP for the following.

  Create a new image

  Put your name using the text tool.

  Use various filters to make a logo of your name.

  Autocrop image to text size.

SOP  3 :  Use Inkscape for the following.

  Draw a simple landscape using basic geometric shapes.

  Use gradient tool for the same.

SOP 4 :  Use Inkscape for the following.

  Load an Id size image, 

   Make 12 copies of it. 

   Arrange in 4 rows x 3 columns on an A4 size page.

SOP 5 :  Use Inkscape for the following.

 You are starting a new business. 

   Create an advertisement to be published in local newspaper promoting your 
product or services. 

   Size should be 210 x 210 mm.

  Create your own visiting card using inkscape.

SOP 6 :  Using Inkscape make the following picture.

 



Skill Set 5 - Digital Content Creation


